Okay
  Public Ticket #2061707
Calendar issue
Open

Comments

  •  3
    Petro started the conversation

    Hello,
    there is also one strange issue in the calender.

    I tried to translate the days in German. Everything was ok until I came to Monday.
    When I translate Monday, Days change there places. Saturday becomes Monday and the other days come after Saturday. 

    I'll better show you the screenshots:

    1. Before Translation :

    https://prnt.sc/o7aft1

    2. After Translation:

    https://prnt.sc/o7agiz

    Hope you solve this issue as soon as possible.

    Thank you in advance for your help!
    Best regards,
    Petro Kozak

  •  276
    Abhishek replied

    Hello,

    Please refer to the latest reply by François here

    https://alkaweb.ticksy.com/ticket/2060348

    Kind Regards,

    Abhishek 

    Want feedback on your awesome Intranet? Get yourself a beta access on Feedier.com.

    Keen on Woffice ? Please take a few seconds to give us a 5-star review on ThemeForest.

  •  3
    Petro replied

    Hello,

    I've read the ticket that you've sent to me. But thats not the thing Im asking about. 
    Im able to translate the String , its all fine. 

    But when I translate them and save the translation, days in the calendar change their placing. You can see it on the screenshot that I've sent to you.

    And this issue happes after saving the translation of only one String -"Monday".  When I translate Monday, Saturday becomes Monday and all other days change their place. That was the issue I want to solve, not the translation itself.

    Best regards,

    Petro Kozak

  • Marcel replied

    Hi, I have exactly the same issue, also mentioned in that particular ticket but indeed the answer is not solving it at all.

    Have a look the screenshot, I guess everyone who is translating the strings has this issue.

    BTW: it takes really an awefull lot of time before issues addressed here in the public tickets are 1. understood and 2. answered.

    Kind regards,

    Marcel.

    Attached files:  Schermafbeelding 2019-06-26 om 10.59.15.png

  •  620
    François replied

    Hi there, 

    Thanks for your patience and the bug report guys, we're looking into it. 

    Who do have some customers who translated it fine, so that's why we're having some issues to reproduce it. 

    @Petro, is there a way you can send me access to your site and FTP access as well. In a private reply. I would be able to debug it from there.

    Have a nice day.

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •   Petro replied privately
  •  620
    François replied

    Hello Petro, 

    Can you update your theme to version 2.8.4 please: http://hub.alka-web.com/woffice/changelog

    As we did quite some updates on that Calendar in the past 2 months. 

    You can try to re-save the extension settings on re-select the translated Monday as starting date, because if the English one was saved, that'd create that issue.

    Then, I'm seeing with our dev team to reproduce it but I don't have an easy fix right now.

    Have a nice day

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,

    if I will put my purchase data into Woffice updater Extension, will the theme be automatically updated?

    Best regards,
    Petro Kozak

  •  3
    Petro replied

    Hello,
    I do not really understand how it works with the WOffice Updater. 
    I've already put my account data in the required field, saved  settings, and nothing happened.
    How do I get the update with the Woffice Updater?

    Best regards,

    Petro Kozak

  • Marcel replied

    @Francois

    I have the same issue as I mentioned earlier and I am on a fresh install (3 weeks) updated last week to 2.8.4 and then the issue appeared.

    I followed your instructions to "re-save the extension settings on re-select the translated Monday as starting date" but that doesn't help. 

    Look at the screenshots for 3 examples of 3 different starting days, it keeps using the english name and then start with the translated ones and adds a 8th column name.

    Kind regards,

    Marcel.

    Attached files:  Schermafbeelding 2019-07-03 om 11.31.14.png
      Schermafbeelding 2019-07-03 om 11.31.49.png
      Schermafbeelding 2019-07-03 om 11.32.20.png

  •  620
    François replied

    Hi Marcel, 

    Can you open a new ticket with some access to your site please so that we can have a closer look. 

    @Pedro, once setup and that you get the status "Checked", you will receive a WordPress notification whenever there is an update published. It might not work on the first shot, but will for the next one publishedsmile.png 

    See: https://alkaweb.atlassian.net/wiki/spaces/WOF/pages/229722

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,

    before I update I want to ask you some more questions.

    1. I have  woffice-child-theme file on my server. But the child theme is not displayed in Design- Themes. 
    What should I do so that the child theme is displayed?

    2. When I update woffice manually from server, should I also delete the child theme file, or should the child theme file stay?

    Best regards,
    Petro Kozak

  •  620
    François replied

    Hi Petro, 

    1. That means it's incorrect (the format), otherwise you'd see it in the Themes listing on your WordPress admin. You can use the one from the main package as an example, it's woffice-child-theme.zip, that one is validsmile.png You can use that one and make your changes on top of it. 

    2. You shouldn't change the child theme, only the themes/woffice directory. 

    Let me know if you need more details here

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,

    I made an update. Now I have a version 2.8.4.
    Now The calendar problem got even worse. Because thats how the calendar looks right now:

    https://prnt.sc/oavp3d

    Can you please solve it? 
    I sent you my Admin data, but didnt see that you was logged in even once. 

    Other users have the same issue as I , and they try to get your help even longer than I.

    Could you please try to slove those issues? 
    Because as for now, my Calendar is 100% unfunctional.

    Thank you in advance. 
    Best regards,
    Petro Kozak

  •  620
    François replied

    Hi Petro, 

    Can you update the Woffice Core plugin to the version 2.8.4 (Appearance > Install Plugins) and refresh your browser's cache. 

    That'll fix the issuesmile.png 

    Let me know if you need more details. 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,

     I updated a plugin to 2.8.4. I already have it.

    I cleared my browsers cache. Tried in 4 different browsers: Chrome,  Mozilla,  Opera and Internet Explorer.

    Calendar appears now.   But the issue with  Days in Calendar, which are fully displaced after trying to translate them, is still there. Look at the Screenshot.

    https://prnt.sc/obxyhx

    Best regards,
    Petro Kozak


  •  620
    François replied

    Hi Petro, 

    I do see the issue. But can't reproduce it :/ 

    Can you send me FTP access please so I can have a look on your site and fix it. 

    Keep me posted

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Helllo,
    I understand your situation.
    But this problem is not only our problem. This problems seems to appear by multiple users. So I wonder that you are not able to reproduce it. However, if you fix it only for us, I will be not sure, that your fixing does not dissappear after the update.
    Saving fixed files and then add them after each update is also not the way I would work with this. 

    Are you not able to solve this issue centralised?  Because it is definetely your internal issue, because it appear by multiple users.

    Is it possible to solve it in that way?

    Best regards,
    Petro Kozak

  •  620
    François replied

    Hello Petro, 

    With FTP access, yes, I can fix it on your side and test it. Which is the whole point. Then when it's fixed on your side I will apply the same fix to the main theme so you don't have any issue when updating the themesmile.png 

    Let me know if you need more details. 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •   Petro replied privately
  •  620
    François replied

    Not finding the Woffice theme. See attached image. 

    Am I in the wrong directory? 

    Attached files:  CUSTOMER.jpg

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  620
    François replied

    Hello, 

    So if you replace this file: 

    woffice/inc/plugins/woffice-core/extensions/woffice-event/static.php

    With the one attached.

    And then in your child theme's functions.php: 

    add_filter('woffice_events_frontend_config', function($config) {
        $config['starting_day'] = 'Montag';
        return $config;
    });

    That should do the jobsmile.pngKeep me posted

    Attached files:  static.php

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •   Petro replied privately
  •  620
    François replied

    Hi Petro, 

    I fixed it on your site but please make sure to apply the changes on your end as well, in your child theme (see last message) so it stays in the next update. 

    Have a nice daysmile.png

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,
    thank you very much!

    I have  one question more:

    if I install one of your Demo Contents, what will happen with all of the changes you've made?

    Best regards,
    Petro Kozak

  •  620
    François replied

    No prob'smile.png 

    Nothing, as these changes are on the Woffice files and the demo content in the database. However, it'll re-build your site's content. So you must be sure you have nothing valuable.

    Have a nice day

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,

    the calendar problem is not fixed till the end.   Calendar works normally for the Admin, but doesnt work for the simple User.

    Look at the screenshot below.

    Hope you will fix this. 

    Best regards,
    Petro Kozak

    Attached files:  simple user.png

  •  620
    François replied

    Can you either: 

    - Try in an incognito browser, with a clean cache.

    - Make sure on the Plugins page that the Woffice Core plugin is at version 2.8.4 and not below. 

    - Send me some access to that account if the first 2 are not working. 

    Keep me posted, 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello, 
    it started to work!
    Thank you!

    Best regards,
    Petro Kozak

  •  276
    Abhishek replied

    Hello,

    Glad it works now! Don't hesitate in asking if you need further assistance.

    Have a nice daysmile.png

    Kind Regards,

    Abhishek 

    Want feedback on your awesome Intranet? Get yourself a beta access on Feedier.com.

    Keen on Woffice ? Please take a few seconds to give us a 5-star review on ThemeForest.

  •  1
    Rmgroup98 replied

    Hi,

    I've got a similar problem. I tried using the shordcode as well but it still looks weird. 

    P.S. I've already have the latest woffice update.

    Thanks for your help.

    Attached files:  cal issue.JPG

  •  276
    Abhishek replied

    Hello Rmgroup98,

    I already replied to your issue in 

    https://alkaweb.ticksy.com/ticket/2086591

    Kind Regards,

    Abhishek 

    Want feedback on your awesome Intranet? Get yourself a beta access on Feedier.com.

    Keen on Woffice ? Please take a few seconds to give us a 5-star review on ThemeForest.

  • Andreas replied

    Hi Abhishek,

    i have a question to the changes in the functions.php in the child theme you provide

    And then in your child theme's functions.php: 

    add_filter('woffice_events_frontend_config', function($config) {
        $config['starting_day'] = 'Montag';
        return $config;
    });

    That should do the jobsmile.pngKeep me posted

    The only problem then is if you have more languages e.g. German and English then in one of these its not working.
    Without change it not works in German, with change not in English 

  •  3
    Petro replied

    Hello,

    yes, I have exactly the same issue! I discovered it today, when I created the English Version of calendar page.

    It seems like you've just set Montag as a constant name for a starting day. But it should not be just set. User should be able to translate the String, and this seems still be impossible.

    Hope you will solve this as soon as possible.

    Best regards,
    Petro Kozak

  •  620
    François replied

    It was added to the translation file last week, so you should see it with the new .POT version. This filter is just more general and sure way to fix and change itsmile.png 

    We're still looking into it.

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello,

    what filter are you talking about?

    Im talking about the issue that this ticket was started with.  The days in the calendar are not in the right places.

    You fixed it for German, but now German word "Montag" appear in all languages as a starting day of a week.

    Look at the screenshot attached.

    The peace of code that you sent to me solves the issue only for German. But when I want to use multiple languages, the issue is still there. 

    Best regards,
    Petro Kozak


    Attached files:  29.07.png

  •  620
    François replied

    Hi Petro, 

    Do you have a function to get language? You can do something like: 

    add_filter('woffice_events_frontend_config', function($config) {
        $config['starting_day'] = (get_language() === 'NL') ? 'Hey' : 'Montag';
        return $config;
    });

    And replace 

    get_language()

    With your multilanguage plugin's function that gives the current language, they all have one.

    The problem is that the value (translated) is saved in the database so you cannot translate it before. We'll see to get that fixed in the next update.

    Have a nice day

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  • Andreas replied
    add_filter('woffice_events_frontend_config', function($config) {    $config['starting_day'] = (get_language() === 'NL') ? 'Hey' : 'Montag';    return $config;
    });

    If I try this with german 'DE' and TranslatePress the complete site will not work anymore

  •  620
    François replied

    Hello, 

    get_language()

    Was an example, sorry the misunderstanding here. You  need to use the function from your multilanguage plugin that lets you get the current the language. 

    They all have onesmile.png

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  • Andreas replied

    I find by myself. For those who interested, with TranslatePress this will work for e.g. German and English:

    add_filter('woffice_events_frontend_config', function($config) {
    $current_language = get_locale();
    if( $current_language == 'en_EN' ){
    $config['starting_day'] = 'Monday';
    }
    if( $current_language == 'de_DE' ){
    $config['starting_day'] = 'Montag';
    }
        return $config;
    });

  •  3
    Petro replied

    Hello dear Alkaweb team,

    as written before, I dont want to try something, what Im not sure about. So, I hope you get the issue fixed by the next update, as you've promised before.

    Best regards,
    Petro Kozak

  •  620
    François replied

    Hello Petro, 

    We'll see to get that fixed, if you need it now, go in your language plugin's doc and get the function that returns the name. Then replace get_language() with the name of that function. 

    There might be not any easy way to handle that, as it's an option with many languages, we'll test, but using that filter is a bullet proof (or at least updates) to get rid of that issue. 

    Have a nice day.

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  3
    Petro replied

    Hello, 

    we will wait until the issue gets fixed by you, because we are not the professional developers and we dont want to do something wrong with the code. So, we will wait until you fix the issue.

    Thank you for your help! Hope to see some update news from you soon)

    Best regards,
    Petro Kozak