Okay
  Public Ticket #2031773
Breadcrumbs in single post pages
Open

Comments

  •  2
    Luca Comelli started the conversation

    Hi,

    Where are my breadcrumbs, in single post pages?!?

    How ca I enable it?

    Thanks in advance!

    Attached files:  Bread.png

  •  606
    François replied

    Hi Luca, 

    There is an extension that should helpsmile.png 

    See attached image and let me know if you need any specific detail here. 

    Attached files:  Unyson_‹_Woffice_dev_—_WordPress.jpg

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    Ok, I put the code

    <?php //BREADCRUMBS
    if( function_exists('fw_ext_breadcrumbs') ) { fw_ext_breadcrumbs(); } ?>

    in my child theme single.php file, under the code

    <?php  //GET THEME HEADER CONTENT

    woffice_title(get_the_title()); ?>

    ... but no way! No breadcrumbs under my FEATURED TITLE!

    Attached files:  Breadcrumbs.jpg

  •  606
    François replied

    Hello, 

    THat'd be a CSS issue here. Can you try it first in the content part, under the #content div, and check with a: 

    <h1>I'm working</h1>
    <?php //BREADCRUMBS
    if( function_exists('fw_ext_breadcrumbs') ) { fw_ext_breadcrumbs(); } ?>

    To make the template is working. If that doesn't work, we'll open an issue on our side and make sure it's being fixed in the next updatesmile.png 

    Keep me posted

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    "IM WORKING" works... but no breadcrumbs!

    Attached files:  Schermata 2019-06-05 alle 09.03.33.png
      Schermata 2019-06-05 alle 09.03.52.jpg

  •  606
    François replied

    Hi there, 

    I found the issue Luca, we have an update coming today: 2.8.3.2. It'll contain the fixsmile.png 

    I'll try to release it this morning. 

    Have a nice day.

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    Perfect, solved!

  •  606
    François replied

    Greatsmile.png Have a nice day. 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    ONE MOMENT...

    In the WooCommerce Shop now I have 2 breadcrumbs 1 above the other...

    Attached files:  Schermata 2019-06-06 alle 12.15.52.jpg

  •  606
    François replied

    Hello, 

    Thanks for the bug report, I'm pushing a 2.8.3.3 update tomorrow morning to resolve this issue. 

    Have a nice day. 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    Ok, did you find the bug?

    In my child theme I've put the following code in functions.php, maybe it's related?

    /**

     * Rename "home" in breadcrumb

     */

    add_filter( 'woocommerce_breadcrumb_defaults', 'wcc_change_breadcrumb_home_text' );

    function wcc_change_breadcrumb_home_text( $defaults ) {

        // Change the breadcrumb home text from 'Home' to 'Apartment'

    $defaults['home'] = 'Shop Home';

    return $defaults;

    }

    /**

     * Replace the home link URL

     */

    add_filter( 'woocommerce_breadcrumb_home_url', 'woo_custom_breadrumb_home_url' );

    function woo_custom_breadrumb_home_url() {

        return get_permalink(102);

    }

  •  606
    François replied

    No, it's on our side and related to the fix on the breadcrumbs on single post pages. And yes, we found the bug and fixed it.

    I'm sending you the change. See attached image. But it'll be live tomorrow. 

    // CHECK FOR BREADCRUMB
                    if (
                            !is_front_page() &&
                            function_exists('fw_ext_breadcrumbs') &&
                            !is_singular('wiki')
                    ) {
                        if ((function_exists('is_woocommerce') && is_woocommerce()) || (function_exists('is_product') && is_product())) {
                            woocommerce_breadcrumb( array(
                                'delimiter'   => '',
                                'wrap_before' => '<div class="woobread breadcrumbs" itemprop="breadcrumb">',
                                'wrap_after'  => '</div>',
                                'before'      => '',
                                'after'       => '',
                            ) );
                        } else {
                            fw_ext_breadcrumbs();
                        }
                    }
    

    Attached files:  Item-0_and_Item-0_and_Item-0_and_Item-0_and_Item-0_and_Item-0_and_Item-0_and_Item-0.jpg

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    Hi, version 2.8.3.3 solved the "breadcrumbs" problem!

    But today, logged as ADMIN, my post appear in FRONTEND EDIT mode:

    (see attachment)

    1. How can disable it?

    2. In this mode, the "Scarica il PDF" button are not working, but for a non-editor user works...

    Can you help me please?

    Attached files:  schermata.png

  •  606
    François replied

    Hi there, 

    Great! 

    Not sure I understand the issue here, could you send me some access to that very specific page so I can understand what's going on. 

    Have a nice day. 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •   Luca Comelli replied privately
  •  606
    François replied

    Hi Luca, 

    Can you do a backup of your site and try 2 things: 

    - Deactivate the Time tracking Woffice extension and give it another shot. To see if that makes any difference. 

    - If not, please deactivate the Woffice theme, switch to the default theme and try again to make sure it does work without Woffice. In order to confirm it's caused by Woffice. 

    Have a nice day here.

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    The "Time Tracking trick" doesn't work...

    Are you SURE I must try another Theme?! I'm scared about loosing some settings...

    Before the 2.8.3.3 update it just works...

    Whit a NORMAL USER this button works!

  •  606
    François replied

    Hi Luca, 

    It had no impact on this feature, that's why it should be fine. I am asking you this because that Time Tracking extension is creating a JavaScript issue in the console.  

    You can do a backup first using:

    https://wordpress.org/plugins/updraftplus/

    Or the Unyson backup extensions. It's important because that'd help us narrow down the issue. 

    Because I don't see, except that JavaScript error, how Woffice would have an impact. 

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    Yes, but time tracking is deactivated from this morning... with no results!

  •  606
    François replied

    Okay, and the final test: when you deactivate the theme? You can just switch for 10 min, that's finesmile.png 

    Let me know if you need more details and keep me posted please

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/

  •  2
    Luca Comelli replied

    Ok, I make a clone site for test purposes: "provaextra.extra.bredasys.com".

    With default theme (Twenty Fifteen) it's all ok...

    Attached files:  Schermata 2019-06-12 alle 14.49.22.png

  •  2
    Luca Comelli replied

    OK, SOLVED!

    It was AUTOPTIMIZE "HTML Optimize" setting that conflict with your theme!

  •  606
    François replied

    Hi there, 

    Thanks for the bug report, and glad you fixed it, we'll look into that. 

    Have a nice daysmile.png

    Kind Regards,

    François 

    Want feedback on your awesome site? Get yourself a beta access on our new product Feedier.com here: https://feedier.com/